Problem mit Umlauten und Sonderzeichen nach FW Update

Probleme mit dem SolarLog? "Hier werden Sie geholfen!"

Problem mit Umlauten und Sonderzeichen nach FW Update

Beitragvon VeronaFeldbusch » Do 19. Nov 2015, 19:14

Hallo,

seit dem Update auf die 3er FW werden die Umlaute und Sonderzeichen
auf der Homepage nicht mehr richtig angezeigt.

Solarlog intern ==> Homepage
€ ==> €
15° flach nach Süden ==> 15° flach nach Süden

Was kann das sein?

Gruß Verona
7,995 kWp - 37 IBC 215TS - Solarmax 2000C + Mastervolt QS 6400i
2,160 kWp - 12 Day4 180 - Solarmax 5000P String1
2,250 kWp - 10 Sanyo HIP225HDE1 - Solarmax 5000P String2
1,890 kWp - 06 Sunpower 315 - Mastervolt QS 2000
http://www.solarlog-home.de/heckmann
VeronaFeldbusch
****
 
Beiträge: 345
Registriert: Di 17. Feb 2009, 22:57

Re: Problem mit Umlauten und Sonderzeichen nach FW Update

Beitragvon Solarfuzzi2003 » Do 3. Mär 2016, 10:38

Das selbe Problem habe ich auch. Es wird kein € Zeichen angezeigt sondern €????
Hat einer ne Lösung für dieses Problem? :ohno:

Gruß Solarfuzzi2003
Solarfuzzi2003
*
 
Beiträge: 1
Registriert: Di 23. Feb 2016, 11:21

Re: Problem mit Umlauten und Sonderzeichen nach FW Update

Beitragvon Rabe » Sa 5. Mär 2016, 13:30

Versuchs doch mal im Solarlog mit Eingabe der html-Syntax (zum Bleistift € statt € oder ü statt ü) - dann könnte die Darstellung auf der Homepage wieder passen.
viele Grüße vom Raben
Benutzeravatar
Rabe
****
 
Beiträge: 161
Registriert: Mi 17. Nov 2010, 20:02

Re: Problem mit Umlauten und Sonderzeichen nach FW Update

Beitragvon VeronaFeldbusch » Mo 7. Mär 2016, 10:12

Hallo,

Danke füt den Tip...

Bei den Sonderzeichen und Umlauten hat es geklappt,
weil das kann ich im Solarlog ändern.

Das mit dem Euro Zeichen klappt nicht,
weil es in der Homepage selber erzeugt wird,
bzw. warscheinlich in den Ländereinstellungen.

Sollte aber machbar sein.

Gruß Verona
7,995 kWp - 37 IBC 215TS - Solarmax 2000C + Mastervolt QS 6400i
2,160 kWp - 12 Day4 180 - Solarmax 5000P String1
2,250 kWp - 10 Sanyo HIP225HDE1 - Solarmax 5000P String2
1,890 kWp - 06 Sunpower 315 - Mastervolt QS 2000
http://www.solarlog-home.de/heckmann
VeronaFeldbusch
****
 
Beiträge: 345
Registriert: Di 17. Feb 2009, 22:57

Re: Problem mit Umlauten und Sonderzeichen nach FW Update

Beitragvon Schuggi » Di 26. Apr 2016, 15:14

Hallo,
das liegt daran, das der SolarLog nun das €-Zeichen in Unicode überträgt.
Ich hab mir das mal angeschaut und ich denke ich hab da eine relativ einfache Fehlerbehebung gefunden.
Einfach die markierte Zeile (siehe Bild) in die visu.html reinschreiben.

Bei älteren Varianten vom selfmade passiert der Fehler nicht.

Mit dieser Zeile wird die Angabe aus der base_vars.js überschrieben.

Gruß
Schuggi

PS: Ausprobieren geht auf eigene Gefahr!
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Benutzeravatar
Schuggi
****
 
Beiträge: 105
Registriert: Mi 4. Aug 2010, 07:52


Zurück zu Wenn was nicht funktioniert...

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast