Virus-Meldung auf slexpert.de und hlcsb.de

Probleme mit dem SolarLog? "Hier werden Sie geholfen!"

Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Mi 22. Sep 2010, 02:21

Hallo,

seit zwei Tagen bekomme ich beim Zugriff auf meine Scripte vom Virusscanner eset nod32 eine Warnung vor einem "JS/Redirector.NAU Trojaner". Seit dem 21.9. nun auch beim Kaspersky. Ich vermute, das auch andere Virenscanner in Kürze nachziehen werden.

Ein vollständiger Scan meiner Rechner mit verschiedenen Antivirentools ergab keinen Befund. Durchgeführt wurden die Scans von Live-CDs unter WinBuilder 7PE 2010 und verschiedenen Linux-Varianten (z.B. Knoppix). Auch habe ich die Inhalte von slexpert.de und hlcsb.de gelöscht und neu übertragen. Eine tatsächliche Infizierung der Seiten mit dem gemeldeten Virus wage ich somit zu bezweifeln.

Auch habe ich meine gesamten angeblich infizierten Scripte bei eset zur Prüfung eingeschickt - aber noch keine Rückmeldung erhalten.

Die Ursache für die Warnmeldungen dürfte in der Verschlüsselung der HTML/JavaScript-Scripte in Verbindung mit dem dynamischen Nachladen von vermeidlichen Codeteilen sein. Ein solches Vorgehen wird anscheinend von Virenautoren genutzt. In meinen Scripten besteht das Nachladen von Codeteilen allerdings aus dem Nachladen von immer wieder genutzten Funktionen und den SolarLog-Daten-Dateien - also den *.js-Dateien, ohne die einer Auswertung nicht möglich ist. Genau diese Vorgehensweise verwenden auch die originalen SDS-Scripte.

Wenn ich die HTML/JavaScript-Scripte unverschlüsselt nutze, so erfolgt keine Warnung. Auf die Verschlüsselung kann ich aber leider nicht verzichten, da es einige Zeitgenossen gab und gibt, die sich ohne Achtung meines geistigen Eigentums meine Script als ihre ausgegeben haben und zum Teil sich auch Heute noch damit (finanzielle) Vorteile verschaffen.

Inzwischen habe ich die Verschlüsselungsmethode geändert und damit gibt es zumindest bei eset nod32 keine Warnungen mehr. Wie es sich bei anderen Virenscannern verhält, konnte ich noch nicht prüfen.

Ich hoffe, das ich durch die geänderte Verschlüsselung die Scanner beruhigen kann, alternativ müsste ich meine Seiten komplett vom Netz nehmen und durch die Originale ersetzen.

Sonnige Grüße
Harald
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon Südwestsonne » Mi 22. Sep 2010, 12:23

Hallo Harald,
auch ich hatte diese Warnmeldungen von eset nod32. Noch heute früh hat mein Rechner im Büro (der war 2 Tage nicht an) eine Virenmeldung gebracht als sich das Gadget aktualisierte. Kurze Zeit später funktioniert alles reibungslos. Hat die Meldung eventuell mit einer Virendatei von Nod32 zu tun. Ich habe schon immer Nod32 im Einsatz und noch nie Probleme.

Gruß Mario
Benutzeravatar
Südwestsonne
****
 
Beiträge: 192
Registriert: So 1. Mär 2009, 09:40
Wohnort: Schkopau

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Mi 22. Sep 2010, 18:25

Als Notlösung - bis die Virenscanner wieder gut von böse unterscheiden können - habe ich zumindest für die visu.html die Originalversion bereit gestellt.
Damit auf jeden Fall erst mal eine Überwachung wieder möglich.

Sonnige Grüße
Harald
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon weinbergen » Mi 22. Sep 2010, 21:28

Hallo,
ist das der Grund warum die aktuellen Daten wider im Solarlog-Standart angezeigt werden ?
weinbergen
***
 
Beiträge: 33
Registriert: Sa 18. Sep 2010, 00:33

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Mi 22. Sep 2010, 22:45

weinbergen hat geschrieben:ist das der Grund warum die aktuellen Daten wider im Solarlog-Standart angezeigt werden ?


ja. Bei der erweiterten Version kann ich zur Zeit nicht sicherstellen, das sie ohne Probleme angezeigt werden kann. Damit aber dennoch die Überwachung und Auswertung weiterhin möglich ist, habe ich vorübergehend die originale SolarLog-Seite eingebunden.

Allerdings mit der Einschränkung, das Anlagen aus der "Solar-Log™ WEB Classic 2nd Edition" zur Zeit nicht dargestellt werden können.

Sonnige Grüße
Harald
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon lehmann28 » Do 23. Sep 2010, 14:15

Ich will jetzt hier niemanden in Schutz nehmen, aber wie manche Leute auf die Virusmeldung reagieren und dazu noch andere künstlichen Kriegsnebenschauplätze regenerieren finde ich schon sehr bedauerlich. Haralds SLexpert-Version hat bei einigen Antivirenprogrammen angeschlagen, aber der Entwickler bzw. Betreiber dieser Zusatzfunktionen reagierte direkt und ergriff Gegenmaßnahmen . Also ist doch alles bestens.

Wenn ich da manchmal sehe welche Kinderkrankheiten Microsoft-Software hat, Druckertreiber von großen Herstellern nicht ordentlich funktionieren, andere Websites ihre Seiten mit Flashwerbung zukleistern, SAT-Receiver bei der kleinsten Spannungsschwankung abschmieren oder sonstige Fehler in der heutigen Welt vollkommen gelassen als Gott gegeben hingenommen wird, da sind die seltsamen unbegründeten Antivirenmeldungen doch Kinderkram gegen. Außerdem hängt von der Funktion kein Menschenleben ab.

Klar ist es ärgerlich, aber mit etwas mehr Sachlichkeit und Menschenverstand kommt man da bestimmt schneller vorwärts. Sollten sich so einige Leute in unserer Gesellschaft mal zu Herzen nehmen und drüber nachdenken. Besonders diejenigen, die immer über andere Leute unterschwellig rumlästert .

Der Tom 8-)
It's the first day, of the rest of your life.
Benutzeravatar
lehmann28
*****
 
Beiträge: 1215
Registriert: Sa 21. Feb 2009, 17:21

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon Südwestsonne » Do 23. Sep 2010, 15:02

Es hat doch gar keiner geschipft, oder habe ich was nicht mitbekommen.

Gruß Mario
Benutzeravatar
Südwestsonne
****
 
Beiträge: 192
Registriert: So 1. Mär 2009, 09:40
Wohnort: Schkopau

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon weinbergen » Do 23. Sep 2010, 18:20

Vielleicht könnte Harald einfach wieder alles aktivieren. Da müssen halt die Virenscanner manuell angepasst werden. Momentan kann man zwischen den tagen nicht hin und her schalten bzw.keinen Tag mehr aus dem Monat auswählen. Es steht dann da "undefined"
weinbergen
***
 
Beiträge: 33
Registriert: Sa 18. Sep 2010, 00:33

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Do 23. Sep 2010, 18:36

weinbergen hat geschrieben:Vielleicht könnte Harald einfach wieder alles aktivieren. Da müssen halt die Virenscanner manuell angepasst werden. Momentan kann man zwischen den tagen nicht hin und her schalten bzw.keinen Tag mehr aus dem Monat auswählen. Es steht dann da "undefined"


Tschuldigung - da gab es in der originalen Version einen kleinen Bug. Da dieser Bereich in der originalen Version von SDS aber auch von mir stammte, ist es meine Schuld :oops:

Der Fehler ist behoben.

Ich habe noch ein paar Tests vor und werde vermutlich im Laufe des Abends die erweiterte Version wieder freischalten.

Sonnige Grüße
Harald
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Do 23. Sep 2010, 18:37

Südwestsonne hat geschrieben:Es hat doch gar keiner geschipft, oder habe ich was nicht mitbekommen.


vermutlich bezieht sich Tom da auf ein anderes Forum.
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon weinbergen » Do 23. Sep 2010, 18:51

das399igste hat geschrieben:
weinbergen hat geschrieben:Vielleicht könnte Harald einfach wieder alles aktivieren. Da müssen halt die Virenscanner manuell angepasst werden. Momentan kann man zwischen den tagen nicht hin und her schalten bzw.keinen Tag mehr aus dem Monat auswählen. Es steht dann da "undefined"


Tschuldigung - da gab es in der originalen Version einen kleinen Bug. Da dieser Bereich in der originalen Version von SDS aber auch von mir stammte, ist es meine Schuld :oops:

Der Fehler ist behoben.

Ich habe noch ein paar Tests vor und werde vermutlich im Laufe des Abends die erweiterte Version wieder freischalten.

Sonnige Grüße
Harald



Super Harald... Danke im Vorraus ! :beer: :sun:
weinbergen
***
 
Beiträge: 33
Registriert: Sa 18. Sep 2010, 00:33

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon Ostfriesenstrom » Fr 24. Sep 2010, 15:39

Moin Harald,

vielen Dank für deine Bemühungen, hat sicherlich wieder einiges an Nerven und Freizeit gekostet.

Bei mir läuft es wieder und sieht so doch auch viel besser aus, wobei ich auch davor keine Probleme hatte, mein Bitdefender hatte sich nicht gemuxt.

Gruß von der Küste

Roman
Benutzeravatar
Ostfriesenstrom
****
 
Beiträge: 178
Registriert: Sa 21. Feb 2009, 20:58
Wohnort: 26759 Hinte

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon BOBO » Fr 24. Sep 2010, 17:21

Servus Harald,

bei mir funzt jetzt auch wieder alles. Mein Virenscanner F-Secure hat allerdings auch nicht angeschlagen.

Danke für die Vorsichtsmaßnahmen

Gruß

BOBO
Benutzeravatar
BOBO
****
 
Beiträge: 888
Registriert: Sa 21. Feb 2009, 16:20
Wohnort: südlich von München

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon JoSAT » Fr 24. Sep 2010, 21:19

Hallo Harald,

leider kann ich momentan keine guten Nachrichten melden. (Vielleicht bist du auch grad dran?)
Ich kann meine Daten überhaupt nicht sehen, da Kaspersky dicht macht mit der Meldung:

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Der Zugriff auf die angeforderte URL ist nicht möglich
Im angeforderten Objekt unter der URL-Adresse:

http://www.solarlog-home.de/das399igste/
SolarLog-Shop24/anlageninfo.html?url=www.
solarlog-home5.de/solarlight

wurde eine Bedrohung gefunden:
Das Objekt ist mit Trojan-Downloader.JS.Small.ov infiziert
Diese Meldung wurde erstellt:
20:51:00
Kaspersky Security Suite CBE 10

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Bei uns in der Firma, kam heute sogar ein Anruf von der IT, sie müssten vor Ort kommen und als ADMIN mein PC scannen, da mein PC mit Viren verseucht sei. Lustig, gell?

Trotzdem Harald, wir kriegen das hin! Las reden wer will, du findest auch hier wieder eine Lösung.

MUSS HIER MAL SAGEN: DEINE ARBEIT IST KLASSE
Danke, dass du dir Zeit nimmst für uns.
----------------------------------------
grüsse
JoSAT
JoSAT
*
 
Beiträge: 5
Registriert: So 29. Nov 2009, 21:36

Re: Virus-Meldung auf slexpert.de und hlcsb.de

Beitragvon das399igste » Fr 24. Sep 2010, 22:19

Ich finde das ganze leider nicht so zum Lachen.

Inzwischen ist auch Solare-Datensysteme bei mir vor stellig geworden. Es ist durchaus möglich, das meine Seiten dort verschwinden.

Leider gibt es noch viele, die in ihrer links.html auf alte Scripte verlinken, die bei SDS liegen. Ich habe diese dort zwar fast alle inzwischen durch Weiterleitungen zu mir ersetzen können, aber mit der Zeit hat sich doch so einiges angesammelt. Sollte SDS nun aber meine Seiten löschen, würden die Links ins Leere laufen und die Nutzer hätten einen leeren Bildschirm.

Auch das bei einigen auf der Arbeit die Admins kritische Fragen stellen ist auch nicht witzig. Bei mir sind inzwischen auch alle Seiten durch den Proxy gesperrt, was mir das Testen deutlich erschwert.

Und von meinen bei eset eingereichten Dateien habe ich bis jetzt noch nichts gehört.

Sonnige Grüße
Harald
Alles meine persönliche Meinung. Ohne Gewähr für Vollständigkeit oder Richtigkeit.
Mitglied im SFV
Bild Bild
Benutzeravatar
das399igste
Mod
 
Beiträge: 993
Registriert: Mo 9. Feb 2009, 23:40
Wohnort: Region Hannover

Nächste

Zurück zu Wenn was nicht funktioniert...

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron